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EXPORTING 
ASSETS 

 
Lesson overview 
In this lesson, you’ll learn how to do the following: 

• Create pixel-perfect drawings. 

• Use the Export For Screens command. 

• Work with the Asset Export panel. 

• Generate, export, and copy/paste CSS (Cascading Style Sheets) code. 
 

This lesson takes approximately 30 minutes to complete. Please log in 
to your account on peachpit.com to download the lesson files for this 
chapter, or go to the “Getting Started” section at the beginning of this 
book and follow the instructions under “Accessing the lesson files and 
Web Edition.” 

Your Account page is also where you’ll find any updates to the chapters 
or to the lesson files. Look on the Lesson & Update Files tab to access the 
most  current content. 
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You can optimize your Illustrator CC content for use 
on the Web, in apps, and in screen presentations 
using various methods. For example, you can easily 
export assets and save them for the web or apps, 
export CSS and image files, and generate SVG 
(Scalable Vector Graphics). 
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● Note: If you 
have not already 
downloaded the project 
files for this lesson to 
your computer from 
your Account page, 
make sure to do so 
now. See the “Getting 
Started” section at the 
beginning of the book. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
● Note: If you don’t 
see Reset Essentials in 
the Workspace menu, 
choose Window > 
Workspace > Essentials 
before choosing 
Window > Workspace > 
Reset Essentials. 

Starting the lesson 
Before you begin this lesson, you’ll restore the default preferences for Adobe 
Illustrator CC and open the lesson file. 

1 To ensure that the tools function and the defaults are set exactly as described 
in this lesson, delete or deactivate (by renaming) the Adobe Illustrator CC 
preferences file. See “Restoring default preferences” in the “Getting Started” 
section at the beginning of the book. 

2 Start Adobe Illustrator CC. 

3 Choose File > Open. In the Open dialog box, navigate to the Lessons > Lesson15 
folder. Select the L15_start.ai file, and click Open. This lesson contains a fictitious 
business name, address, and website address for the purposes of the project. 

4 The Missing Fonts dialog box will most 
likely appear. Click Sync Fonts to sync 
all the missing fonts to your computer 
(your list may not match the figure). 
After they are synced and you see the 
message stating that there are no more 
missing fonts, click Close. 

● Note: If you can’t get the fonts to sync, you can 
go to the Creative Cloud desktop application and 
choose Assets > Fonts to see what the issue may 
be (refer to the section “Changing font family and 
font style” in Lesson 8, “Adding Type to a Poster,” 
for more information on how to resolve it). You can also just click Close in the Missing Fonts dialog 
box and ignore the missing fonts as you proceed. A third method is to click the Find Fonts button in 
the Missing Fonts dialog box and replace the fonts with a local font on your machine. 

 
5 Choose Window > Workspace > Reset Essentials to ensure that the workspace is 

set to the default settings. 

6 Choose View > Fit Artboard In Window. 

7 Choose File > Save As. In the Save As dialog box, 
navigate to the Lessons > Lesson15 folder, and 
name the file AssetExport.ai. Leave the Format 
option set to Adobe Illustrator (ai) (macOS) 
or the Save As Type option set to Adobe 
Illustrator (*.AI) (Windows) and then click Save. 
In the Illustrator Options dialog box, leave the 
Illustrator options at their default settings and 
then click OK. 

8 Choose Select > Deselect, if  necessary. 
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Creating Pixel-Perfect Drawings 
When creating content for use on the Web, in mobile apps, in onscreen 
presentations, and more, it’s important that images saved from vector art look 
sharp. To enable designers to create pixel-accurate designs, you can align artwork 
to the pixel grid using the Snap To Pixel option. The pixel grid is a grid of 72 
squares per inch, vertically and horizontally, that is viewable when you zoom to 
600% or higher with Pixel Preview mode enabled (View > Pixel Preview). 

Pixel-aligned is an object-level property that enables an object to have its vertical 
and horizontal paths aligned to the pixel grid. This property remains with the 
object when the object is modified. Any vertical or horizontal path in the object 
gets aligned to the pixel grid as long as the property is set for it. 

Aligning new artwork to the pixel grid 
When Snap To Pixel (View > Snap To Pixel) is enabled, shapes that are drawn, 
modified, or transformed appear crisp. This makes most artwork, including most 
Live Shapes, align to the pixel grid automatically. In this first section, you’ll explore 
the pixel grid and how to align new content to it. 

1 In the AssetExport.ai file, choose File > Document Color Mode, and you will see 
that RGB Color is selected. 

When designing for onscreen viewing (web, apps, etc.), RGB (Red, Green, Blue) 
is the preferred color mode for documents in Illustrator. When you create a 
new document (File > New), you can choose which color mode to use with the 
Color Mode option. In the New Document dialog box, choosing any document 
profile, except for Print, sets Color Mode to RGB by default. 

2 Select the Selection tool ( ), and click to select the brown circle with the word 
“ACCESSORIES” beneath it. Press Command++ (macOS) or Ctrl++ (Windows) 
several times to zoom in closely to the selected artwork. 

3 Choose View > Pixel Preview to preview a rasterized version of the design. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
� Tip: After you 
create a document, 
you can change the 
document color mode 
using File > Document 
Color Mode. This sets 
the default color mode 
for all new colors you 
create and the existing 
swatches. RGB is the 
correct color mode 
to use when creating 
content for the Web, for 
apps, or for onscreen 
presentations. 

 
 
 
 
 
 

Preview mode Pixel Preview mode 
 

When you export assets in a format such as GIF, JPG, or PNG, any artwork that 
was vector is rasterized in the resulting file. Turning on Pixel Preview is a great 
way to be able to see what the artwork will look like when it’s rasterized. 
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� Tip: You can turn off 
the pixel grid by 
choosing Illustrator CC > 
Preferences > Guides & 
Grid (macOS) or Edit > 
Preferences > Guides 
& Grid (Windows) and 
deselecting Show 
Pixel Grid (Above 
600% Zoom). 

 
 
 
 
 
 
 
 
 
● Note: As of the 
writing of this book, the 
creation tools affected 
by Snap To Pixel are the 
Pen tool, the Curvature 
tool, shape tools like 
the Ellipse tool and the 
Rectangle tool, the Line 
Segment tool, the Arc 
tool, Grid tools, and the 
Artboard tool. 

 
 
� Tip: You can also 
click the Snap To Pixel 
option in the Properties 
panel with nothing 
selected and the 
Selection tool selected, 
or you can select the 
Align Art To Pixel Grid 
option ( ) on the right 
end of the Control panel 
(Window > Control). 

4 Choose 600% from the View menu in 
the lower-left corner of the Document 
window (in the Status bar), and make 
sure you can still see the brown circle 
above the “ACCESSORIES” text. 

By zooming in to at least 600% and 
with Pixel Preview turned on, you can 
see a pixel grid appear. The pixel grid 
divides the artboard into 1 pt. (1/72- 
inch) increments. For the next steps, 
you need to see the pixel grid (zoom level of 600% or greater). 

5 Click to select one of the white paths on the brown circle. 

This is an easy way to set the stroke and fill formatting for the next object drawn 
to match the selected artwork. 

6 Select the Rectangle tool ( ) in the 
Tools panel. Draw a simple rectangle 
on the brown circle. 

You might notice that the edges of the 
rectangle look a little “fuzzy.” That’s 
because in this document, Snap To 
Pixel is turned off. 

7 Press Delete or Backspace to remove 
the rectangle. 

8 Choose View > Snap To Pixel to turn on Snap To Pixel. 

Now, any shapes that are drawn, modified, or transformed will snap to the pixel 
grid if possible. By default, Snap To Pixel is turned on when you create a new 
document that uses the Web or Mobile document profile. 

9 With the Rectangle tool selected, draw 
a simple rectangle to complete the 
coffee cup on the brown circle, and 
notice that the edges are “cleaner.” 

The vertical and horizontal segments 
of the drawn artwork snap to the pixel 
grid. In the next section, you’ll see 
that you can snap existing artwork to 
the pixel grid. In this case, I had you 
redraw the shape just to see the difference. 
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10 Select the Selection tool ( ), and drag 
the rectangle into position like you see 
in the figure. You may need to resize 
the rectangle to look better. 

 
 
 
 
 
Aligning existing artwork to the pixel grid 
You can also align existing artwork to the pixel grid in several ways, as you will do 
in this section. 

1 Select the Selection tool ( ), and click to select the rounded rectangle above the 
rectangle you drew. 

2 Click the Align To Pixel Grid button in the Properties panel to the right (or 
choose Object > Make Pixel Perfect). 

 

The rounded rectangle was created when Align To Pixel Grid wasn’t selected. 
After the rectangle was aligned to the pixel grid, the horizontal and vertical 
straight edges were snapped to the closest pixel grid lines. Live Shapes and Live 
Corners are preserved when doing this. 

Objects that you pixel-align that do not have any straight vertical or horizontal 
segments are not modified to align to the pixel grid. For example, because a 
rotated rectangle does not have straight vertical or horizontal segments, it is not 
nudged to produce crisp paths when the pixel-aligned property is set for it. 
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● Note: The Align 
To Pixel Grid button 
does not appear in 
the Properties panel 
when an open path 
is selected. 

3 Click to select one of the wavy white lines above the rounded rectangle, which 
selects a group of lines. Choose Object > Make Pixel Perfect. 

 
 
 
 
 
 
 

You will see a message in the Document window, “Selection Contains Art That 
Cannot Be Made Pixel Perfect.” In this case, this means there are no vertical or 
horizontal straight edges to align. 

4 Click the white “handle” shape on the right side of the coffee mug. Press 
Command++ (macOS) or Ctrl++ (Windows) several times to zoom in closely to 
the selected artwork. 

5 Drag the upper-right corner bounding point to make the handle a bit  larger. 
 
 
 
 
 
 
 
 
 
 
 
● Note: Moving 
artwork is constrained 
to be in whole pixels 
when transforming 
via the Selection tool, 
Direct Selection tool, 
Live Shape center 
widget, arrow keys, 
and Artboard tool. The 
Direct Selection tool 
snaps anchor points 
and handles to pixel 
or subpixel locations 
depending on the 
stroke settings of the 
path. This snap is similar 
to the Pen tool snap 
during creation. 

 
After dragging, notice that resizing the shape using the corner or side handles 
fixes the corresponding edges (snaps them to the pixel grid) but not all of them. 

6 Choose Object > Make Pixel Perfect 
to ensure that all of the vertical or 
horizontal straight edges are aligned to 
the pixel grid. 

7 Choose Select > Deselect (if available) 
and then choose File >  Save. 
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Exporting artboards and assets 
In Illustrator, using the File > Export > Export For Screens command and the 
Asset Export panel, you can export entire artboards, perhaps to show a design 
in progress, or selected assets. The exported content can be saved in several file 
formats, such as JPEG, SVG, PDF, and PNG. These formats are optimized for use 
on the Web, devices, and onscreen presentations and are compatible with most 
browsers, yet each has different capabilities. The selected artwork is automatically 
isolated from the rest of the design and saved as an individual file. 

 
 
 
� Tip: To learn more 
about working with 
web graphics, search 
for “File formats for 
exporting artwork“ 
in Illustrator Help 
(Help > Illustrator Help). 

 

 
● Note: To learn 
more about creating 
slices, search for 
“Create slices“ in Adobe 
Illustrator Help (Help > 
Illustrator Help). 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

Exporting artboards 
In this section, you’ll see how to export artboards in your document. This could be 
useful if you want to show someone a design you are working on or to capture a 
design for use in a presentation, website, app, or other. 

1 Choose View > Fit Artboard In Window. 

2 Choose File > Export > Export For  Screens. 

In the Export For Screens dialog box that appears, you can choose between 
exporting artboards and exporting assets. Once you decide what to export, you 
can set export settings on the right side of the dialog box. 
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Slicing content 
In the past, before the Export For Screens command or the Asset Export panel, 
you needed to isolate artwork you wanted to export. This was done by placing the 
artwork on its own artboard or by slicing the content. In Illustrator, you can create 
slices to define the boundaries of different web elements in your artwork. When you 
save the artwork using the File > Export > Save For Web (Legacy) command, you can 
choose to save each slice as an independent file with its own format and settings. 

 
It is not necessary to isolate 
artwork by slicing when using 
the File > Export > Export For 
Screens command or Asset 
Export panel since artwork is 
isolated automatically. 
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3 With the Artboards tab selected, on the right side of the dialog box, ensure that 
All is selected. 

 

You can choose to export all or a specific range of artboards. This document has 
only one artboard, so selecting All is the same as selecting a range of 1. Selecting 
Full Document will export all artwork in a single file. 

4 Click the folder icon ( ) to the right of the Export To field. Navigate 
to the Lessons > Lesson15 folder, and click Choose (macOS) or Select 
Folder (Windows). 

5 Click the Format menu, and choose JPG 80. 
 

 

 
 
 
 
 
 
� Tip: To avoid 
creating subfolders, 
like the folder “1x,” you 
can deselect Create 
Sub-folders in the Export 
For Screens dialog box 
when exporting. 

In the Formats section of the Export For Screens dialog box, you can set a Scale 
factor for the exported asset, create (or in this case edit) a suffix for the filename, 
and change the format. You can also export multiple versions with different 
scale factors and formats by clicking the + Add Scale button. 

6 Click Export Artboard. 

The Lesson15 folder should open, and you should see a folder named “1x” and, 
in that folder, an image named “Artboard 1-80.jpg.” The “-80” suffix refers to the 
quality you set when exporting. 

7 Close the folder, and return to Illustrator. 
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Exporting assets 
You can also quickly and easily export individual assets in file formats such as 
JPG, PNG, and SVG using the Asset Export panel. The Asset Export panel lets 
you collect assets that you might export frequently and can be a great tool for web 
and mobile workflows because it allows for the export of multiple assets with a 
single click. In this section, you’ll open the Asset Export panel and see how to both 
collect artwork in the panel and use it to export that collected artwork. 

1 With the Selection tool ( ) selected, click to select the white “Pluralist” logo at 
the top of the  artboard. 

2 Press Command++ (macOS) or Ctrl++ (Windows) several times to zoom in 
closely to the logo. 

3 With the logo selected, choose Window > Asset Export to open the 
Asset Export panel. 

The Asset Export panel is where you can save content for export now or later. 
It can work in conjunction with the Export For Screens dialog box to set export 
options for the selected assets, as you’ll see. 

4 Drag the selected Pluralist logo into the top part of the Asset Export panel. When 
you see a plus sign (+) appear, release the mouse button to add the artwork to the 
Asset Export panel. 

 
 
● Note: There are 
several methods for 
exporting artwork in a 
variety of formats. 
You can select artwork 
in your Illustrator 
document and choose 
File > Export Selection. 
This adds the selected 
artwork to the Asset 
Export panel and opens 
the Export For Screens 
dialog box. You can 
choose from the same 
formats you saw in the 
previous section. 

 
 
 
 

 
� Tip:   To add artwork to the 
Asset Export panel, you 
can also right-click the 
artwork in the 
Document window and 
choose Collect For 
Export > either As 
Single Asset or As 
Multiple Assets. 

 

 
 
 
 
 
 
 

The artwork you added to the panel is now called “pluralist” or something similar. 
The asset is tied to the original artwork in the document. In other words, if you 
update the artwork in the document, the asset is updated in the Asset Export 
panel. Every asset you add to the Asset Export panel is saved with the panel and 
will be in there until you delete it from either the document or the Asset panel. 
You can also drag multiple objects into the Asset Export panel, and each will be 
saved as a separate asset. 

� Tip: If you Option-drag (macOS) or Alt-drag (Windows) multiple objects into the Asset Export panel, 
the selected content will become a single asset in the Asset Export panel. 

� Tip: To delete an 
asset from the Asset 
Export panel, you 
can either delete the 
original artwork in the 
document or select the 
asset thumbnail 
in the Asset Export 
panel and click the 
Remove Selected Assets 
From This Panel button. 
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● Note: You may need 
to double-click to edit 
the name. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
● Note: If you are 
creating assets for use 
on iOS or Android, you 
could also click the iOS 
or Android options 
to create a series of 
scaled export options, 
by default. 

5 Click the name of the asset in the Asset Export panel, and rename it 
PluralistLogo. 

 

The asset name that appears is based on what the artwork is named in the 
Layers panel. Also, how you name assets in the Asset Export panel is up to you. 
I name them so later I can more easily keep track of what each asset is used for. 

6 Click the Pluralist logo asset thumbnail to select it in the Asset Export panel. 

As you add more and more assets to the panel using various methods, you will 
need to first select the assets you’d like to export. 

7 In the Export Settings area of the Asset Export panel, choose SVG from the 
Format menu, if necessary. 

The SVG is perfect for the website, but in this case, a co-worker has asked for a 
PNG version of the same logo as well. 

8 Click the + Add Scale button below the SVG option in the panel to export the 
artwork in another format (in this case). Change Scale to 1x and ensure that 
Format is PNG. 
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This sets the format for all of the selected assets in the Asset Export panel. You 
can also set a scale (1x, 2x, etc.) if you need multiple scaled versions of the selected 
assets—perhaps for Retina and non-Retina displays when it comes to formats like 
JPEG or PNG. You can also add a suffix to the exported file name. A suffix could 
be something like “@1x” to indicate the 100% scaled version of an exported asset. 

9 With the PluralistLogo thumbnail selected at the top of the Asset Export panel, 
click the Export button at the bottom of the Asset Export panel to export 
the selected asset. In the dialog box that appears, navigate to the Lessons > 
Lesson15 > Asset_Export folder, and click Choose (macOS) or Select Folder 
(Windows) to export the assets. 

Both the SVG file (PluralistLogo.svg) and the PNG file (PluralistLogo.png) will 
be exported to the Asset_Export folder in separate folders. 

You can also click the Launch The Export For Screens Dialog button ( ) at the 
bottom of the Asset Export panel. This will open the Export For Screens dialog 
box where you can set all of the same settings, including a few more. 
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● Note: Exporting 
or copying CSS from 
Illustrator CC does 
not create HTML 
for a web page. It is 
intended to create 
CSS that is applied 
to HTML you create 
elsewhere, such as in 
Adobe Dreamweaver. 

Creating CSS from your design 
If you are building a website or want to hand off content to a developer, you 
can transform the visual designs you create in Illustrator to Cascading Style 
Sheets styles using the CSS Properties panel (Window > CSS Properties) or 
File > Export > Export As command. Cascading Style Sheets is a specification   for 
formatting rules, much like paragraph and character styles in Illustrator, that 
control the appearance of content in a web page. Unlike paragraph and character 
styles in Illustrator, CSS can control not only the look and feel of text but also the 
formatting and positioning of page elements found in HTML. 

 

 
An example of CSS code. 

 
The great thing about generating CSS from your Illustrator artwork is that it allows 
for flexible web workflows. You can export all of the styling from a document, or 
you can just copy the styling code for a single object or a series of objects and paste 
it into an external web editor, like Adobe Dreamweaver. This can be a great way to 
move the styling from your web design in Illustrator straight to your HTML editor 
or to hand it off to a web developer. But creating CSS styling and using it effectively 
requires a bit of setup in your Illustrator CC document, and that’s what you’ll learn 
about next. 

● Note: To learn more about CSS, visit the “Understand Cascading Style Sheets” section of Adobe 
Dreamweaver Help (https://helpx.adobe.com/dreamweaver/using/cascading-style-sheets.html). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

https://helpx.adobe.com/dreamweaver/using/cascading-style-sheets.html
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Setting up your design for generating CSS 
If you intend to export or copy and paste CSS from Illustrator CC, setting up the 
Illustrator CC file properly before creating CSS allows you to name the CSS styles 
that are generated. In this section, you’ll look at the CSS Properties panel and see 
how you can set up the content for style export using named or unnamed content. 

1 Choose Window > Workspace > Reset   Essentials. 

2 Choose Select > Deselect, if available. 

3 Choose View > Fit Artboard In Window and then press Command+– (macOS) 
or Ctrl+– (Windows) to zoom out. 

4 Choose Window > CSS Properties to open the 
CSS Properties panel. Using the CSS Properties 
panel, you can do the following: 

• Preview CSS code for selected objects. 
• Copy CSS code for selected objects. 
• Export generated styling for selected objects 

to a CSS file (along with any images used). 

• Change options for the CSS code exported. 
• Export the CSS for all objects to a CSS file. 

5 With the Selection tool ( ) selected, click to select the blue rectangle behind 
the navigation and logo at the top of the artboard (see the following figure). 

In the CSS Properties panel you’ll see a message in the preview area. Instead of 
CSS code (which is what the preview area typically shows), the message states that 
the object needs to be named in the Layers panel or you need to allow Illustrator 
to create styling from “unnamed objects.” 

6 Open the Layers panel (Window > Layers), and click the Locate Object 
button ( ) at the bottom of the panel to easily find the selected object in 
the panel. 
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● Note: You may need 
to drag the left edge of 
the Layers panel to the 
left to see the entire 
name of the object. 

 
● Note: The content 
for the sublayer named 
“pluralist” may be 
showing in your Layers 
panel and that’s okay. 

7 Double-click directly on the name of the selected <Rectangle> object in the 
Layers panel, and change the name to navbar (lowercase). Press Return or Enter 
to make the change. 

 
 
 
 
 
 
 
 
 
 
 
 

8 Look in the CSS Properties panel again, and you should see a style named 
.navbar in the preview area. Drag the bottom of the panel down to show more. 

 

 

● Note: If you 
see a style named 
“.navbar_1_,” it’s usually 
because there is an 
extra space after the 
name “navbar” in the 
Layers panel. 

 
� Tip: You can tell a 
style is a class in CSS 
because the name has a 
period (.) before it. 

When content is unnamed in the Layers panel (it has the default naming), a CSS 
style is not created for it, by default. If you name the object in the Layers panel, 
the CSS is generated, and the name of the style created matches the object name 
in the Layers panel. Illustrator creates styles called classes for most content. 

For objects in the design (not including text objects, as you will see), the name 
you give them in the Layers panel should match the class name in the HTML 
that is created in a separate HTML editor, like Dreamweaver. But, you can also 
forgo naming the objects in the Layers panel and simply create generic styles 
that you can then export or paste into an HTML editor and name there. You 
will see how to do that next. 
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9 With the Selection tool, click to select the 
brown circle behind the cup you worked 
with earlier. In the CSS Properties panel, 
a style will not appear since the object is 
unnamed in the Layers panel (it just has 
the generic <Path> name). 

10 Click the Export Options button ( ) at 
the bottom of the CSS Properties panel. 

The CSS Export Options dialog box that 
appears contains export options that you 
can set, such as which units to use, which properties to include in the styles, and 
other options, such as which Vendor prefixes to include. 

11 Select Generate CSS For Unnamed Objects, and click OK. 
 

12 With the brown circle still selected, a style 
named “.st0” appears in the preview area 
of the CSS Properties panel. 

.st0 is short for “style 0” and is a generic 
name for the formatting that is generated. 
Every object that you don’t name in the 
Layers panel will now be named .st1, .st2, 
and so on, after turning on Generate CSS 
For Unnamed Objects. This type of style 
naming can be useful if, for instance, you 
are creating the web page yourself and you are going to paste or export the CSS 
from Illustrator and name it in your HTML editor or if you simply needed some 
of the CSS formatting for a style you already have in your HTML editor. 

13 Choose Select > Deselect and then choose File > Save. 
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● Note: Currently, 
paragraph styles are 
not taken into account 
when naming styles 
in the CSS code that 
is generated. 

Working with character styles and CSS code 
Illustrator will create CSS styles based on text formatting, as well. Formatting, 
such as font family, font size, leading (called line-height in CSS), color, kerning and 
tracking (collectively called letter-spacing in CSS), and more, can be captured in the 
CSS code. Any character styles that are applied to text in your design are listed in 
the CSS Properties panel as a CSS style and have the same name as the character 
style. Text that has formatting applied, without a character style applied, will have a 
generic CSS style name when Illustrator generates the style. 

Next, you’ll create and then apply a character style to text. 

1 In the CSS Properties panel, notice the style named [Normal Character Style], 
toward the top of the panel. 

In the CSS Properties panel, only character styles that are applied to text 
appear. The Normal Character Style is applied to text by default, so it appears in 
the CSS Properties panel. If you create character styles but don’t apply them to 
text, they will not appear in the CSS Properties panel. 

2 Choose Window > Type > Character Styles to open the Character Styles panel. 

3 With the Selection tool (   ) selected, click to select the paragraph of text below 
the heading “BRAND,” on the left end of the footer. 

4 Press Command++ (macOS) or Ctrl++ (Windows) several times to zoom in to 
the text. 

5 Select the Type tool ( ) in the Tools panel. Select the entire paragraph that 
begins with “The Pluralist is a lifestyle brand....” 

6 Click the style named “p” in the Character Styles panel to apply it to the 
selected text. 
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7 Select the Selection tool ( ), and with the text object still selected, you will see 
the character style named “p” in the CSS Properties panel list. This indicates 
that it is applied to text in the design. You will also see CSS code in the preview 
area of the panel. 

 

 
Selecting a text object (not the text) will show all the generated CSS code for the 
styling used in the entire text area. With the text selected, the CSS is not shown 
in the CSS Properties panel. 

8 With the Selection tool, click the type object in the footer that contains the 
“Shopping” heading. Look in the CSS Properties panel, and you will see a series 
of CSS styles listed. These are the styles applied to all the text in the type area. 
You may want to drag the bottom of the CSS Properties panel down to see more 
of the styling. 

Selecting a type area gives you the ability to see all the CSS code generated 
from the styling. It is also a great way to be able to copy or export all the text 
formatting from a selected type area. 

� Tip: You can also 
use the character 
styles listed in the CSS 
Properties panel as a 
way to apply the styles 
to text. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
● Note: The ordering 
of the styles you see 
in the CSS Properties 
panel may not 
match the figure and 
that’s okay. 
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� Tip: Like selecting a 
character style in the 
CSS Properties panel to 
apply the formatting, 
you can also select 
content and select a 
graphic style listed 
in the CSS Properties 
panel to apply it. 

Working with graphic styles and CSS code 
CSS code can also be copied or exported for any graphic styles that are applied to 
content. Next, you’ll apply a graphic style and see the generated CSS code. 

1 Choose View > Fit Artboard In Window. With the Selection tool ( ), click to 
select the blue rectangle behind the ship. You may want to zoom out a bit. 

2 Choose Window > Graphic Styles. In the Graphic Styles panel, click the graphic 
style named “GradientBox.” You can close the Graphic Styles panel    group. 

 
 
 
 
 

Looking in the CSS Properties panel, you will see the graphic style named 
“GradientBox” now listed, because it is applied to content in your document. 

You will also see CSS code for a style. Mine is named “.content_1_,” but yours 
may be different. The CSS code is generated from the GradientBox graphic style 
you just saw since that graphic style is applied. But it’s not naming the style with 
the “GradientBox” name since the graphic style is just a way to apply formatting. 
Remember, this is an unnamed CSS style because you didn’t rename the selected 
object (the rectangle) in the Layers  panel. 

3 Leave the rectangle selected and then choose File > Save. 
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Copying CSS 
At times, you may need to capture only a bit of CSS code from part of your design 
to paste into your HTML editor or to send to a web developer. Illustrator lets you 
copy and paste CSS code easily. Next, you’ll copy the CSS for a few objects and 
learn about how grouping can change the way CSS code is generated. 

1 With the rectangle still selected, click the 
Copy Selected Style button ( ) at the 
bottom of the CSS Properties panel. This 
copies the CSS code currently showing in 
the panel. 

Next, you will select multiple objects 
and copy the generated CSS code at the 
same time. 

2 With the Selection tool ( ) selected and 
the rectangle still selected, Shift-click the 
brown circle to select both objects. 

In the CSS Properties panel, you will not 
see any CSS code since you need to tell Illustrator to generate CSS code for 
more than one selected object. 

3 Click the Generate CSS button ( ) at the bottom of the panel. 

 
 
 
 
 
 
 
 
● Note:   You may see 
a yield sign icon ) at 
the bottom of the panel 
when certain content 
is selected. It indicates 
that not all of the 
Illustrator appearance 
attributes (such as the 
multiple strokes applied 
to the shape) can be 
written in the CSS code 
for the selected content. 

 
 
 
 
 
 

 
� Tip: When CSS code 
appears in the CSS 
Properties panel for 
selected content, you 
can also select part 
of the code, right-click 
the selected code, and 
then choose Copy to 
copy just that selection. 

 
● Note: The styling 
or naming you see 
may be different, and 
that’s okay. 

 
 

The code for two CSS styles, .st0 and .content_1_, now appears in the preview 
area of the CSS Properties panel. Your style names may be different, and that’s 
okay. To see both styles, you may need to scroll down in the panel. Yours may 
also be in a different order, and that’s okay. 

With both styles showing in the CSS Properties panel, you could copy the styles 
and paste them into your HTML editor code or paste them into an email to 
send to a web developer, for instance. 

 
 

ADOBE ILLUSTRATOR CC CLASSROOM IN A BOOK (2018 RELEASE) 447 



From the Library of Alvaro Alvarez  

4 With the Selection tool, click to select the ship. 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
● Note:  The 
styling you see may 
be different, and 
that’s okay. 

In the CSS Properties panel, you will see CSS code for an .image style. That code 
contains a background-image property. When Illustrator encounters artwork  
(or raster images) that it can’t make CSS code from or a group of objects, it 
rasterizes the exported content (not the artwork on the artboard) when you 
export the CSS code. The CSS code that is generated can be applied to an 
HTML object, like a div, and the PNG image will be applied as a background 
image in the HTML object. 

5 Drag a marquee selection across the brown 
circle and cup shapes to select them. 

6 Click the Generate CSS button ( ) at the 
bottom of the CSS Properties panel to generate 
the CSS code for the selected artwork. 

 

 

You will see the CSS code for all the selected objects in the panel. If you were 
to copy the CSS code now, the images would not be created, only the code 
referring to them. To generate the images, you need to export the code, which 
you will do in the next section. 
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7 Choose Object > Group to group the 
objects together. Leave the group selected 
for the next section. 

Notice that, in the CSS Properties panel, a 
single CSS style is now showing (.image). 
Grouping content tells Illustrator to  
create a single image (in this case) from 
the grouped content. Having a single web 
image would most likely be better if you 
intend on placing it on a web page. 

Exporting CSS 
You can also export part or all of the CSS code for your page design. Exporting CSS 
code has the distinct advantages of creating a CSS file (.css) and exporting PNG files 
for content that is considered unsupported. In this section, you will see both methods. 

1 With the group still selected, click the 
Export Selected CSS button ( ) at the 
bottom of the CSS Properties panel. 

2 In the Export CSS dialog box, make sure 
that the filename is AssetExport. Navigate 
to the Lessons > Lesson15 > CSS_Export 
folder, and click Save to save a CSS 
file named AssetExport.css and a PNG 
image file. 

3 In the CSS Export Options dialog box, 
leave all settings at default, and click OK. 

4 Go to the Lessons > Lesson15  > 
CSS_Export folder on your hard drive. In that folder, you should now see the 
AssetExport.css file and an image named image.png. 

As stated earlier, the CSS code that was generated assumes that you are going to 
apply the CSS styling to an object in your HTML editor and that the image will 
become a background image for the object. With the image generated, you can 
use it for other parts of your web page as well. Next, you’ll export all the CSS 
from the design. 

5 Back in Illustrator, choose File > Export > Export As. In the Export dialog box,  
set the Format option to CSS (css) (macOS) or the Save As Type option to CSS 
(*.CSS) (Windows). Change the filename to AssetExport_all, and make sure   
that you navigate to the Lessons > Lesson15 > CSS_Export folder. Click    Export. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
� Tip: You can choose 
a resolution for 
rasterized artwork in 
the CSS Export Options 
dialog box. By default, 
it uses the Document 
Raster Effects resolution 
(Effect > Document 
Raster Effects Settings). 

 
● Note: You can also 
export all of the CSS 
from your design by 
choosing Export All 
from the CSS Properties 
panel menu. If you want 
to change the export 
options first, you can 
set them by clicking the 
Export Options button 
( ) at the bottom of 
the CSS Properties 
dialog box. 

 
 

 
ADOBE ILLUSTRATOR CC CLASSROOM IN A BOOK (2018 RELEASE) 449 



From the Library of Alvaro Alvarez  

 
 
 
 
 
 
 
 
 
 

● Note: Your file 
sorting and icons may 
look different in the 
CSS_Export folder, and 
that’s okay. 

6 In the CSS Export Options dialog box, leave all the options at their default 
settings, and click OK. You most likely will see a dialog box telling you that 
images will be overwritten. Click OK. 

Position and size properties are not added to the CSS code by default. In certain 
situations, you will need to export CSS with those options selected. The Include 
Vendor Pre-fixes option is selected by default. Vendor prefixes are a way for 
certain browser makers (each is listed in the dialog box) to add support for new 
CSS features. You can choose to exclude these prefixes by deselecting them. 

7 Go to the Lessons > Lesson15 > CSS_Export folder, and you will see the new 
CSS file named AssetExport_all.css and a series of images created because the 
Rasterize Unsupported Art option was selected in the CSS Export Options 
dialog box. 

 

8 Return to Illustrator, and choose Select > Deselect. 

9 Choose File > Close to close the file. Save the file if  asked. 
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